The Digital Media Manager plugin only supports the Cisco 4400 Digital Media Player series and Cisco Digital digital media manager pluginMedia Manager software version 5.2.2 or higher. Support for additional models will be added in the near future.

Fill out the form below to purchase the Digital Media Manager Plugin for InformaCast.

 

Cisco Digital Media Player 4400G

Contact Us